印刷
カテゴリ: FreeBSDとLinux
参照数: 596

最近、Ubuntuで、ca-certificates CA認証情報 が更新されちゃったみたいです。

古いイメージのUbuntuだとaptが失敗する場合があるようです。

Dockerfileなんかで、使っていると apt upgradeが出来ないので、構築失敗するみたいですね。

こういう時は、素直に手動でapt upgradeしましょう。

docker run -it --name ubuntu_work ubuntu bash

# apt update

# apt upgrade

# exit

docker commit ubuntu_work ubuntu_stable

docker rm ubuntu_work

で、Dockerfileのubuntuをubuntu_stableにすればOKです。